Flight Link LLC  
Home Company Hardware Software EPIC Order Support
 
HARDWARE
Fixed Wing Hardware

Rotary Wing Hardware

CAT II Simulator

HELI Simulator

Custom Hardware


EPIC System

 



Flight Link Archive


The files listed below are older drivers for Flight Link's advanced flight controls such as the AV-B/AV-IFR Flight Consoles, Sub Panel and digital avionics stacks (KR1/TR1). 

Please Note: The Flight Link GStick III and GStickIII+ use the Microsoft USB drivers built into Windows XP or Vista and do NOT require Flight Link Control Center.

Control Center 5.2.5*  [Install/Update]

Download

Date: Jun. 15, 2012  Windows 7/Vista (32 and 64 bit)
XP (32 bit only)
Size: 3.9MB

Description:
Control Center is a complete graphical interface which links the AV-B, AV-IFR Flight Consoles, KR1/TR1 Avionics Stacks, Power Quadrants as well as the Rudder Control Module and Sub Panel to Flight Simulator X and X-Plane 9.7.

*EPICenter v.1.4.0.1 is required (22.1MB download) and must be installed before Control Center.

If you already have EPICenter v. 1.4.0.1 installed there is no need to uninstall it in order to update Control Center.

Note: Make sure Windows has all the latest updates installed and FSX has been updated to service pack 2. For further info please read FCC Readme before installing.

 


Control Center 4.3.6.1*

Download

Date: Feb. 18, 2009 Windows XP -- 32bit ONLY Size: 5.8MB

Description:
Control Center is a complete graphical interface which links the AV-B, AV-IFR Flight Consoles, Avionics Stacks, Power Quadrants as well as the Rudder Control Module and Sub Panel to Flight Simulator X and X-Plane 9.x.

Make sure Windows has all the latest updates installed and FSX has been updated to service pack 2. For further info please read FCCreadme before installing.


Control Center 3.4.2*

Download

Date: June 2, 2006 Windows 2000/XP -- 32bit ONLY Size: 6.8MB

Description:
Control Center version 3.4.2 is a complete graphical interface which links the AV-B, AV-IFR Flight Consoles, Avionics Stacks, Power Quadrants as well as the RCM and Sub Panel to Flight Simulator 2002/2004 and X-Plane 7.X/8.X.

This version of FCC (3.4.2) REQUIRES FSUIPC by Peter Dowson.

 
 

Also Note: Please Do Not try to run both versions of Flight Link Control Center at the same time!

 

EPICenter is installed with these versions of Control Center -- there is no need to install EPICenter separately.

*These Files are no longer supported by Flight Link
.
 

CUSTOMER SERVICE:           California Privacy Policy     Return Policy    Contact Us